

  <!DOCTYPE html>
  <html  lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# " prefix="og: http://ogp.me/ns#">
    <head>
      <title>Sweet Earth Plant-Based Entrée Bowls | Progressive Grocer</title>
      <style>
                body {
          --c-accent: #dc2632;
          --c-accent-alt: #b10007;
          --c-accent-rgb: 220, 38, 50;
          --font-headings: Archivo;
          --font-body: Lora;
          --font-nav: Open Sans;
          --font-nav-weight: normal
        }
      </style>

      
      
      <meta charset="utf-8" /><script type="text/javascript">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</script>
<script>window.dataLayer = window.dataLayer || []; window.dataLayer.push({"drupalLanguage":"en","drupalCountry":"US","siteName":"Progressive Grocer","entityCreated":"1655897367","entityLangcode":"en","entityStatus":"1","entityUid":"26","entityUuid":"bca0d6f4-cbe0-485f-988e-1906d3ba065d","entityVid":"106501","entityName":"bgoldschmidt","entityType":"node","entityBundle":"product","entityId":"65872","entityTitle":"Sweet Earth Plant-Based Entr\u00e9e Bowls","entityTaxonomy":{"tags":{"30":"New Products \u0026 Promotions","49":"Frozen Foods"}},"userUid":0,"entityPrimaryTopic":"New Products \u0026 Promotions","userRoles":["anonymous"]});</script>
<meta name="description" content="Korean BBQ-Style Chik’n, Cacio e Pepe are flavorful on-the-go options" />
<meta name="keywords" content="Sweet Earth Plant-Based Entrée Bowls, Global Flavors, Non-GMO, Vegan, Vegetables" />
<meta property="og:site_name" content="Progressive Grocer" />
<meta property="og:type" content="Product" />
<meta property="og:url" content="https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls" />
<meta property="og:title" content="Sweet Earth Plant-Based Entrée Bowls" />
<meta property="og:description" content="Korean BBQ-Style Chik’n, Cacio e Pepe are flavorful on-the-go options" />
<meta property="og:image" content="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/sweet_earth_plant-based_entree_bowls_teaser.jpg?itok=uP62JDNq" />
<meta property="og:image:url" content="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/sweet_earth_plant-based_entree_bowls_teaser.jpg?itok=uP62JDNq" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="655" />
<meta property="og:image:height" content="368" />
<meta property="og:updated_time" content="2022-06-22T06:33:21-0500" />
<meta property="og:image:alt" content="Sweet Earth Plant-Based Entree Bowls Teaser" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Korean BBQ-Style Chik’n, Cacio e Pepe are flavorful on-the-go options" />
<meta name="twitter:title" content="Sweet Earth Plant-Based Entrée Bowls" />
<meta name="twitter:url" content="https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls" />
<meta name="twitter:image:alt" content="Sweet Earth Plant-Based Entree Bowls Teaser" />
<meta name="twitter:image:height" content="368" />
<meta name="twitter:image:width" content="655" />
<meta name="twitter:image" content="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/sweet_earth_plant-based_entree_bowls_teaser.jpg?itok=uP62JDNq" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Archivo:500,500italic,700,700italic,italic,regular|Lora:500,500italic,700,700italic,italic,regular|Open+Sans:300,300italic,italic,regular&amp;subset=latin&amp;display=swap" media="all" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "Article",
            "articleBody": "Aiming to provide convenient plant-based options with the global flavors that consumers desire, Sweet Earth Foods has debuted two frozen entrée bowls, Korean BBQ-Style Chik’n and Cacio e Pepe. Both bowls are Non-GMO Project Verified, vegan, and made with wholesome, veggie-forward ingredients, and each serving contains 15-16 grams of protein and 5-7 grams of fiber. Inspired by the growing popularity of Korean cuisine, savory Korean BBQ-Style Chik’n combines plant-based ingredients like sweet, spicy Korean BBQ-style Chik’n with such veggies as edamame, carrots, snap peas and sesame seeds over a cauliflower-and-brown-rice blend, while gluten-free Cacio e Pepe, based on  the popular pasta dish originating from Rome, features a creamy vegan parmesan-style-cheese-and-black-pepper sauce made from cashews over chickpea pasta with added veggies. A 9-ounce package of either variety retails for a suggested $4.99.\r\n\r\n \r\n\r\n \r\n\r\n ",
            "headline": "Sweet Earth Plant-Based Entrée Bowls",
            "name": "Sweet Earth Plant-Based Entrée Bowls",
            "about": [
                "\u003Ca href=\u0022/new-products-promotions\u0022 hreflang=\u0022en\u0022\u003ENew Products \u0026 Promotions\u003C/a\u003E",
                "\u003Ca href=\u0022/frozen-foods\u0022 hreflang=\u0022en\u0022\u003EFrozen Foods\u003C/a\u003E"
            ],
            "description": "Korean BBQ-Style Chik’n, Cacio e Pepe are flavorful on-the-go options",
            "datePublished": "\u003Ctime datetime=\u00222022-06-27T12:00:00Z\u0022\u003EMon, 06/27/2022 - 12:00\u003C/time\u003E",
            "dateModified": "\u003Ctime datetime=\u00222022-06-27T12:00:00Z\u0022\u003EMon, 06/27/2022 - 12:00\u003C/time\u003E"
        }
    ]
}</script>
<meta http-equiv="ImageToolbar" content="false" />
<link rel="preconnect" href="https://fonts.googleapis.com/" />
<link rel="preconnect" href="https://www.googletagservices.com/" />
<link rel="preconnect" href="https://www.googleadservices.com/" />
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" />
<link rel="preconnect" href="https://googleads.g.doubleclick.net/" />
<link rel="preconnect" href="https://fonts.gstatic.com/" />
<link rel="preconnect" href="https://www.google-analytics.com/" />
<link rel="preconnect" href="https://tpc.googlesyndication.com/" />
<link rel="preconnect" href="https://pagead2.googlesyndication.com/" />
<link rel="preconnect" href="https://olytics.omeda.com/" />
<link rel="preconnect" href="https://clientcdn.pushengage.com/" />
<link rel="preconnect" href="https://www.linkedin.com/" />
<link rel="preconnect" href="https://connect.facebook.net/" />
<link rel="preconnect" href="https://www.facebook.com/" />
<link rel="preconnect" href="https://dc.ads.linkedin.com" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com/" />
<script type="text/javascript">
  // Initialize the google variables.
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  // Add a place to store the slot name variable.
  googletag.slots = googletag.slots || {};
  (function() {
    var useSSL = "https:" == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();

  // Get a cookie by name
  function getTargetingCookie(name) {
    var cookies = document.cookie.split(';');
    var i = 0;
    var target = '';
    while (i < cookies.length && target == '') {
      if (cookies[i].indexOf(name) > -1) {
        target = cookies[i].split('=').pop();
        break;
      }
      i++;
    }

    return target;
  }

</script>
<script type="text/javascript">
        // Start by defining breakpoints for this ad.
      var mapping = googletag.sizeMapping()
              .addSize([100, 2], [600, 450])
            .build();
  
  googletag.slots["interstitial_1"] = googletag.defineSlot("/86468407/progressive_grocer/pg-interstitial-1", [600, 450], "js-dfp-tag-interstitial_1")

    .addService(googletag.pubads())

  
  
  
      .setTargeting('pg-topic', ['New\u0020Products\u0020\u0026\u0020Promotions','Frozen\u0020Foods'])
      .setTargeting('pg-content-type', ['product'])
      .setTargeting('pg-blog-series', ['default'])
      .setTargeting('sponsored', ['false'])
      .setTargeting('ad-targeting-id', ['65872'])
        // Apply size mapping when there are breakpoints.
    .defineSizeMapping(mapping)
    ;

    // Adding uncacheable targets.
  if (typeof referrer != "undefined" && referrer) {
    googletag.slots["interstitial_1"].setTargeting('referrer-topic', [referrer]);
  }
  if (typeof company != "undefined" && company && company != 'None') {
    googletag.slots["interstitial_1"].setTargeting('visitor-company', [company]);
  }


</script>
<script type="text/javascript">
        // Start by defining breakpoints for this ad.
      var mapping = googletag.sizeMapping()
              .addSize([1024, 90], [728, 90])
              .addSize([0, 0], [320, 50])
            .build();
  
  googletag.slots["content_leader_2"] = googletag.defineSlot("/86468407/progressive_grocer/pg-contentpage-body-2", [728, 90], "js-dfp-tag-content_leader_2")

    .addService(googletag.pubads())

  
  
  
      .setTargeting('pg-content-type', ['product'])
      .setTargeting('pg-topic', ['New\u0020Products\u0020\u0026\u0020Promotions','Frozen\u0020Foods'])
      .setTargeting('pg-blog-series', ['default'])
      .setTargeting('ad-targeting-id', ['65872'])
      .setTargeting('sponsored', ['false'])
        // Apply size mapping when there are breakpoints.
    .defineSizeMapping(mapping)
    ;

    // Adding uncacheable targets.
  if (typeof referrer != "undefined" && referrer) {
    googletag.slots["content_leader_2"].setTargeting('referrer-topic', [referrer]);
  }
  if (typeof company != "undefined" && company && company != 'None') {
    googletag.slots["content_leader_2"].setTargeting('visitor-company', [company]);
  }


</script>
<script type="text/javascript">
        // Start by defining breakpoints for this ad.
      var mapping = googletag.sizeMapping()
              .addSize([1024, 90], [300, 250])
              .addSize([0, 0], [320, 50])
            .build();
  
  googletag.slots["content_sidebar_2"] = googletag.defineSlot("/86468407/progressive_grocer/pg-contentpage-sidebar-2", [300, 250], "js-dfp-tag-content_sidebar_2")

    .addService(googletag.pubads())

  
  
  
      .setTargeting('pg-content-type', ['product'])
      .setTargeting('pg-topic', ['New\u0020Products\u0020\u0026\u0020Promotions','Frozen\u0020Foods'])
      .setTargeting('pg-blog-series', ['default'])
      .setTargeting('ad-targeting-id', ['65872'])
      .setTargeting('sponsored', ['false'])
        // Apply size mapping when there are breakpoints.
    .defineSizeMapping(mapping)
    ;

    // Adding uncacheable targets.
  if (typeof referrer != "undefined" && referrer) {
    googletag.slots["content_sidebar_2"].setTargeting('referrer-topic', [referrer]);
  }
  if (typeof company != "undefined" && company && company != 'None') {
    googletag.slots["content_sidebar_2"].setTargeting('visitor-company', [company]);
  }


</script>
<script type="text/javascript">
        // Start by defining breakpoints for this ad.
      var mapping = googletag.sizeMapping()
              .addSize([1024, 90], [300, 250])
              .addSize([0, 0], [320, 50])
            .build();
  
  googletag.slots["content_sidebar"] = googletag.defineSlot("/86468407/progressive_grocer/pg-contentpage-sidebar-1", [300, 250], "js-dfp-tag-content_sidebar")

    .addService(googletag.pubads())

  
  
  
      .setTargeting('pg-content-type', ['product'])
      .setTargeting('pg-topic', ['New\u0020Products\u0020\u0026\u0020Promotions','Frozen\u0020Foods'])
      .setTargeting('pg-blog-series', ['default'])
      .setTargeting('ad-targeting-id', ['65872'])
      .setTargeting('sponsored', ['false'])
        // Apply size mapping when there are breakpoints.
    .defineSizeMapping(mapping)
    ;

    // Adding uncacheable targets.
  if (typeof referrer != "undefined" && referrer) {
    googletag.slots["content_sidebar"].setTargeting('referrer-topic', [referrer]);
  }
  if (typeof company != "undefined" && company && company != 'None') {
    googletag.slots["content_sidebar"].setTargeting('visitor-company', [company]);
  }


</script>
<script type="text/javascript">
        // Start by defining breakpoints for this ad.
      var mapping = googletag.sizeMapping()
              .addSize([1024, 90], [728, 90])
              .addSize([0, 0], [320, 50])
            .build();
  
  googletag.slots["content_leader"] = googletag.defineSlot("/86468407/progressive_grocer/pg-contentpage-body-1", [728, 90], "js-dfp-tag-content_leader")

    .addService(googletag.pubads())

  
  
  
      .setTargeting('pg-content-type', ['product'])
      .setTargeting('pg-topic', ['New\u0020Products\u0020\u0026\u0020Promotions','Frozen\u0020Foods'])
      .setTargeting('pg-blog-series', ['default'])
      .setTargeting('ad-targeting-id', ['65872'])
      .setTargeting('sponsored', ['false'])
        // Apply size mapping when there are breakpoints.
    .defineSizeMapping(mapping)
    ;

    // Adding uncacheable targets.
  if (typeof referrer != "undefined" && referrer) {
    googletag.slots["content_leader"].setTargeting('referrer-topic', [referrer]);
  }
  if (typeof company != "undefined" && company && company != 'None') {
    googletag.slots["content_leader"].setTargeting('visitor-company', [company]);
  }


</script>
<script type="text/javascript">
googletag.cmd.push(function() {

      googletag.pubads().enableAsyncRendering();
          googletag.pubads().collapseEmptyDivs(true);
        googletag.pubads().disableInitialLoad();
    
  googletag.enableServices();
});

</script>
<link rel="icon" href="https://assets1.progressivegrocer.com/files/2020-03/2017-12-12-1.png" type="image/png" />
<link rel="canonical" href="https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls" />
<link rel="shortlink" href="https://progressivegrocer.com/node/65872" />
<script src="/sites/default/files/google_tag/primary/google_tag.script.js?re2ko9" defer></script>

      
      <link rel="stylesheet" media="all" href="/modules/custom/ash_util/css/processing_indicator.css?re2ko9" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_QOwDOFqc8MBL_VjgHpI1GqCvchshFI8U9hG9YBAtZ3I.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_A8z0tOcOseoDqoOOmxplOWT84ZhFYqh2XaOzDxw8m4k.css" />
<link rel="stylesheet" media="all" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_Cxy4ZVbV0hyTa14_gTr9veaYjml5Sx25gXu7M5QwxHc.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Open+Sans+Condensed:300,700|Open+Sans:300,400,700" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_ctMzoUKC8jN7RY7i7D1UcHRPl9ZErc8ozu0SDRUK_8U.css" />

      <script src="/core/assets/vendor/modernizr/modernizr.min.js?v=3.11.7"></script>
<script src="/core/misc/modernizr-additional-tests.js?v=3.11.7"></script>


      
    </head>
    <body class="role-anonymous fontyourface lang-en section-sweet-earth-plant-based-entree-bowls path-node node--type-product">
    <input type="hidden" id="eiq-topic-name" value="New Products &amp; Promotions, Frozen Foods"/><input type="hidden" id="eiq-page-type" value="product"/><a href="#main-content" class="visually-hidden focusable skip-link">
          Skip to main content
        </a><noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TJ48JGK" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas><section class="off-canvas-wrap " data-offcanvas ><div  class="layout-container"><header id="site-header"  class="header"><div  class="header__inner"><div  class="header__primary"><div  class="header__branding"><a
   class="link"
    href="/"
><div  class="header__desktop_logo"><img
   class="logo__image"
  loading="eager"
            src="https://assets1.progressivegrocer.com/files/2021-03/PG_New_Logo_main.png"
      alt="PG Logo"
          style="height: 80px"
      /></div></a><a
   class="link"
    href="/"
><div  class="header__mobile_logo"><img
   class="logo__image"
  loading="eager"
            src="https://assets1.progressivegrocer.com/files/2021-03/PG_New_Logo_m2.png"
      alt="PG Logo"
          style="height: 30px"
      /></div></a></div><div  class="header__search"><div  class="search-bar search-bar--"><form  class="search-bar__form search-bar__form--" action="/search" method="get"><div  class="search-bar__wrapper search-bar__wrapper--"><input name="query" type="text" class="form-item__textfield" aria-label="Search" placeholder="Search"><svg  class="search-bar__icon"

  
      aria-labelledby="title-search"
  
  ><title id="title-search">search</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#search"></use></svg></div></form><svg  class="search-bar__toggle search-bar__toggle--open"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#search"></use></svg><svg  class="search-bar__toggle search-bar__toggle--close"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#close"></use></svg></div></div><div  class="header__subscribe"><a
   class="button button--subtle"
    href="/#subscribe"
>
                  Subscribe
              </a></div></div></div><div  class="header__menu"><nav class="nav"><a href="#" id="toggle-expand"  class="toggle-expand menu"><span  class="toggle-expand__open"><svg  class="toggle-expand__icon"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#menu"></use></svg><span  class="toggle-expand__text visually-hidden">Expand main menu</span></span><span  class="toggle-expand__close"><svg  class="toggle-expand__icon"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#close"></use></svg><span  class="toggle-expand__text visually-hidden">Close main menu</span></span></a><div id="main-nav" class="main-nav"><div  class="toggle-expand__search"><div  class="search-bar search-bar--open"><form  class="search-bar__form search-bar__form--open" action="/search" method="get"><div  class="search-bar__wrapper search-bar__wrapper--open"><input name="query" type="text" class="form-item__textfield" aria-label="Search" placeholder="Search"><svg  class="search-bar__icon"

  
      aria-labelledby="title-search"
  
  ><title id="title-search">search</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#search"></use></svg></div></form></div></div><ul  class="main-menu"><li  class="main-menu__item"><a href="/industry-news" class="main-menu__link" target="" title="Industry News">Industry News</a></li><li  class="main-menu__item"><a href="/research-analysis" class="main-menu__link" target="" title="Research &amp; Analysis" data-drupal-link-system-path="taxonomy/term/19">Research</a></li><li  class="main-menu__item"><a href="https://progressivegrocer.com/e-commerce" class="main-menu__link">E-Commerce</a></li><li  class="main-menu__item"><a href="https://progressivegrocer.com/equipment-design" class="main-menu__link">Equipment &amp; Design</a></li><li  class="main-menu__item"><a href="/center-store" class="main-menu__link" target="" title="Center Store" data-drupal-link-system-path="taxonomy/term/45">Center Store</a></li><li  class="main-menu__item"><a href="/perimeter" class="main-menu__link" target="" title="Perimeter" data-drupal-link-system-path="taxonomy/term/86">Perimeter</a></li><li  class="main-menu__item"><a href="/solutions" class="main-menu__link" target="" title="Solutions" data-drupal-link-system-path="taxonomy/term/89">Solutions</a></li><li  class="main-menu__item"><a href="/events" class="main-menu__link" title="Industry Events" data-drupal-link-system-path="taxonomy/term/36">Events</a></li><li  class="main-menu__item main-menu__item--with-sub"><a href="/top-women-grocery-podcast" class="main-menu__link main-menu__link--with-sub" data-drupal-link-system-path="node/64964">Top Women</a><svg  class="main-menu__icon"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#caret"></use></svg><ul  class="main-menu main-menu--sub main-menu--sub-1"><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="https://progressivegrocer.com/top-women-grocery-podcast" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">Top Women in Grocery Podcast</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="https://progressivegrocer.com/top-women-grocery-videos" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">Top Women in Grocery Videos</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="https://www.topwomeningrocery.com/" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">Top Women In Grocery Event</a></li></ul></li><li  class="main-menu__item main-menu__item--with-sub"><a href="/" title="More Links" class="main-menu__link main-menu__link--with-sub" data-drupal-link-system-path="&lt;front&gt;">More</a><svg  class="main-menu__icon"

  
  
  ><use xlink:href="/themes/custom/ensemble/dist/icons.svg#caret"></use></svg><ul  class="main-menu main-menu--sub main-menu--sub-1"><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/about-us" title="About Us" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="node/53878">About Us</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/advertise" title="Advertise" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="node/53866">Advertise</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/news-briefs" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="news-briefs">News Briefs</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/webinars" title="Webinars" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="taxonomy/term/85">Webinars</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="https://progressivegrocer.com/multimedia" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">Multimedia</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/progressive-grocer-events" title="PG Events" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">PG Events</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/digital-archive" title="Magazine Issues" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="node/53877">Magazine Issues</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/special-reports" title="Special Reports" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="taxonomy/term/102">Special Reports</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/blogs" title="Blogs" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="blogs">Blogs</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/products" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" title="Products" data-drupal-link-system-path="products">New Products</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="https://progressivegrocer.com/contributing-writer-guidelines-progressive-grocer" class="main-menu__link main-menu__link--sub main-menu__link--sub-1">Writer Guidelines</a></li><li  class="main-menu__item main-menu__item--sub main-menu__item--sub-1"><a href="/contact-us" title="Contact Us" class="main-menu__link main-menu__link--sub main-menu__link--sub-1" data-drupal-link-system-path="contact-us">Contact Us</a></li></ul></li></ul></div></nav></div></header><div></div><div  class="main main--with-sidebar"><a id="main-content" tabindex="-1"></a><div  class="main__highlighted"><div class="region-highlighted panel"><div data-drupal-messages-fallback class="hidden"></div><section id="block-contenthero-2" class="block-contenthero-2 block block-block-content block-block-contentb42664eb-1fa3-4290-90a5-a6dac8194a49"></section><section  id="block-dfptagcontentleader1" class="ad-block block-dfptagcontentleader1"><div  class="ad-block__container"><div  class="ad-block__label">
      Advertisement
    </div><div  class="ad-block__spacer" style="min-height:90px"><div id="js-dfp-tag-content_leader"><script type="text/javascript">
            googletag.cmd.push(function() {
                googletag.display('js-dfp-tag-content_leader');
            });
    
    </script></div></div></div></section><section id="block-customadcontentleader1-2" class="block-customadcontentleader1-2 block block-block-content block-block-content48f47a4f-c9e9-426b-a748-9138f0296fdb"></section></div></div><main role="main"  class="main-content main-content--large main-content--with-social main-content--with-sidebar"><div><section id="block-mainpagecontent-3" class="main-page-content block-mainpagecontent-3 block block-system block-system-main-block"><article id="node-65872"  data-history-node-id="65872" role="article" about="/sweet-earth-plant-based-entree-bowls" typeof="schema:product"><header  data-history-node-id="65872" role="article" about="/sweet-earth-plant-based-entree-bowls" typeof="schema:product" class="article-header"><div  class="article-header__date">
      06/27/2022
    </div><h1  class="article-header__heading article-header__heading--">
      Sweet Earth Plant-Based Entrée Bowls
  </h1><span property="schema:name" content="Sweet Earth Plant-Based Entrée Bowls" class="hidden"></span><span property="schema:interactionCount" content="UserComments:0" class="hidden"></span><span property="schema:name" content="Sweet Earth Plant-Based Entrée Bowls" class="hidden"></span><span property="schema:interactionCount" content="UserComments:0" class="hidden"></span><div  class="article-header__meta"></div></header><span property="schema:dateCreated" content="2022-06-22T11:29:27+00:00" class="hidden"></span><div class="view-mode-full"><div class="field-wrapper field field-node--field-content field-name-field-content field-type-entity-reference-revisions field-label-hidden"><div class="field-items"><div class="field-item"><div  class="image-caption image-caption--image-text image-caption--centered image-caption--large de-content-small clearfix" ><div  class="image-caption__image-content image-caption__image-content--right"><div  class="image-caption__image"><div class="field-wrapper field field-paragraph--field-image-media field-name-field-image-media field-type-entity-reference field-label-hidden"><div class="field-items"><div class="field-item"><article><div class="field-wrapper field field-media--field-media-image field-name-field-media-image field-type-image field-label-visually_hidden"><div class="field-label visually-hidden">Image</div><div class="field-items"><div class="field-item"><img
   srcset="https://assets1.progressivegrocer.com/files/styles/max_width_480/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=5ju30bOK 480w, https://assets1.progressivegrocer.com/files/styles/max_width_640/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=R6Fj794t 640w, https://assets1.progressivegrocer.com/files/styles/max_width_800/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=exzHMjvz 800w" sizes="(min-width: 1300px) 375px, (min-width: 920px) 28vw, (min-width: 720px)  50vw, 100vw" class="image"
  loading="lazy"
      srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="
    data-srcset="https://assets1.progressivegrocer.com/files/styles/max_width_480/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=5ju30bOK 480w, https://assets1.progressivegrocer.com/files/styles/max_width_640/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=R6Fj794t 640w, https://assets1.progressivegrocer.com/files/styles/max_width_800/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=exzHMjvz 800w"
        sizes="(min-width: 1300px) 375px, (min-width: 920px) 28vw, (min-width: 720px)  50vw, 100vw"
          src="https://assets1.progressivegrocer.com/files/styles/max_width_480/s3/2022-06/sweet_earth_plant-based_entree_bowls.jpg?itok=5ju30bOK"
      alt="Sweet Earth Plant-Based Entree Bowls Main Image"
          /></div></div></div></article></div></div></div></div></div><div  class="image-caption__text"><div class="field-wrapper field field-paragraph--field-text-area field-name-field-text-area field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item"><p><span><span><span><span><span><span><span>Aiming to provide convenient plant-based options with the global flavors that consumers desire, </span></span></span></span></span></span></span><a href="https://www.goodnes.com/sweet-earth/"><span><span><span><span><span><span><span>Sweet Earth Foods</span></span></span></span></span></span></span></a><span><span><span><span><span><span><span> has debuted two frozen entrée bowls, Korean BBQ-Style Chik’n and Cacio e Pepe. Both bowls are Non-GMO Project Verified, vegan, and made with wholesome, veggie-forward ingredients, and each serving contains 15-16 grams of protein and 5-7 grams of fiber. Inspired by the growing popularity of Korean cuisine, savory Korean BBQ-Style Chik’n combines plant-based ingredients like sweet, spicy Korean BBQ-style Chik’n with such veggies as edamame, carrots, snap peas and sesame seeds over a cauliflower-and-brown-rice blend, while gluten-free Cacio e Pepe, based on</span></span></span></span></span></span></span><span><span><span><span><strong><span><span>  </span></span></strong></span></span></span></span><span><span><span><span><span><span><span>the popular pasta dish originating from Rome, features a creamy vegan parmesan-style-cheese-and-black-pepper sauce made from cashews over chickpea pasta with added veggies. A 9-ounce package of either variety retails for a suggested $4.99.</span></span></span></span></span></span></span></p><p> </p><p> </p><p> </p></div></div></div></div></div></div></div></div></div></article></section><section id="block-ensemble-contentsharelinks" class="block-ensemble-contentsharelinks sticky-social__wrapper"><div  class="sticky-social"><ul  class="sticky-social__list"><li  class="sticky-social__item"><a
   class="sticky-social__link"
      target="_blank"
    href="https://www.facebook.com/sharer/sharer.php?u=https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls"
><svg  class="sticky-social__icon"

  
      aria-labelledby="title-share_facebook"
  
  ><title id="title-share_facebook">share_facebook</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#share_facebook"></use></svg></a></li><li  class="sticky-social__item"><a
   class="sticky-social__link"
      target="_blank"
    href="https://twitter.com/intent/tweet?url=https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls"
><svg  class="sticky-social__icon"

  
      aria-labelledby="title-share_twitter"
  
  ><title id="title-share_twitter">share_twitter</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#share_twitter"></use></svg></a></li><li  class="sticky-social__item"><a
   class="sticky-social__link"
      target="_blank"
    href="https://www.linkedin.com/shareArticle?url=https://progressivegrocer.com/sweet-earth-plant-based-entree-bowls&amp;title=Sweet Earth Plant-Based Entrée Bowls"
><svg  class="sticky-social__icon"

  
      aria-labelledby="title-share_linkedin"
  
  ><title id="title-share_linkedin">share_linkedin</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#share_linkedin"></use></svg></a></li><li  class="sticky-social__item"><a class="sticky-social__link" target="_blank" href="/cdn-cgi/l/email-protection#8cb3fff9eee6e9eff8b1dffbe9e9f8acc9edfef8e4acdce0ede2f8a1ceedffe9e8acc9e2f8fe4f25e9accee3fbe0ffaaede1fcb7eee3e8f5b1c5a9bebcfbede2f8e9e8a9bebcf8e3a9bebcffe4edfee9a9bebcf8e4e5ffa9bebcfcedebe9a9bebcfbe5f8e4a9bebcf5e3f9a2a9bebca9bebce4f8f8fcffb6a3a3fcfee3ebfee9ffffe5fae9ebfee3efe9fea2efe3e1a3fffbe9e9f8a1e9edfef8e4a1fce0ede2f8a1eeedffe9e8a1e9e2f8fee9e9a1eee3fbe0ff"><svg  class="sticky-social__icon"

  
      aria-labelledby="title-share_email"
  
  ><title id="title-share_email">share_email</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#share_email"></use></svg></a></li></ul></div></section><section id="block-eiqpopularproducts-2" class="block-eiqpopularproducts-2 block block-block-content block-block-content30f10dab-1d94-48e4-9ab7-25cf17c85e05"><section  class="grid__section"><div  class="grid__block-header"><h2  class="block-header__heading">
        Other Popular Products
  
  </h2></div><ul  class="grid grid--default"><div  class="product-card"><div  class="product-card__content"><h3  class="product-card__heading"><a
   class="heading__link"
    href="/natural-choice-sandwich-pepperoni"
>
      Natural Choice Sandwich Pepperoni
      </a></h3></div><div  class="product-card__image"><a href=/natural-choice-sandwich-pepperoni tabindex="-1"><picture
   class="image"
><img
   class="image"
  loading="lazy"
            src="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/hormel_natural_choice_sandwich_pepperoni_teaser.jpg?itok=kEh6kP_H"
      alt="Hormel Natural Choice Sandwich Pepperoni Teaser"
          /></picture></a></div></div><div  class="product-card"><div  class="product-card__content"><h3  class="product-card__heading"><a
   class="heading__link"
    href="/ithaca-grillos-pickles-hummus"
>
      Ithaca Grillo’s Pickles Hummus
      </a></h3></div><div  class="product-card__image"><a href=/ithaca-grillos-pickles-hummus tabindex="-1"><picture
   class="image"
><img
   class="image"
  loading="lazy"
            src="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/ithaca_grillos_pickles_hummus_teaser.jpg?itok=TQgN2sN5"
      alt="Ithaca Grillo&#039;s Pickes Hummus Teaser"
          /></picture></a></div></div><div  class="product-card product-card--sponsored"><div  class="product-card__content"><h3  class="product-card__heading"><a
   class="heading__link"
    href="/westfalia-avocados"
>
      Westfalia Avocados
      </a></h3></div><div  class="sponsor-label">
        Sponsored
  
  </div><div  class="product-card__image"><a href=/westfalia-avocados tabindex="-1"><picture
   class="image"
><img
   class="image"
  loading="lazy"
            src="https://assets1.progressivegrocer.com/files/styles/primary_articles_short/s3/2022-06/pg_westfalia_59915_productspotlight_062422.png?itok=1O-Cca_C"
      alt="Avocados All Day Every Day"
          /></picture></a></div></div></ul></section></section></div></main><aside class="main-sidebar" role="complementary"><div><section id="block-eiqproductsmoredetails-2" class="block-eiqproductsmoredetails-2 block block-block-content block-block-content33d648a7-09ea-4649-a56a-dc6760b89771"><div  class="product-details"><div  class="product-details__title"><h3  class="heading">
      For More Details
  </h3></div><div  class="product-details__content"><div  class="product-details__msrp"><p>$4.99
        </div></div></div></section><section  id="block-dfptagcontentsidebar-2" class="ad-block block-dfptagcontentsidebar-2"><div  class="ad-block__container"><div  class="ad-block__label">
      Advertisement
    </div><div  class="ad-block__spacer" style="min-height:250px"><div id="js-dfp-tag-content_sidebar"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
            googletag.cmd.push(function() {
                googletag.display('js-dfp-tag-content_sidebar');
            });
    
    </script></div></div></div></section><section id="block-customadcontentsidebar-2" class="block-customadcontentsidebar-2 block block-block-content block-block-contentd9d0831e-c1b1-465c-93f0-186a83c915a2"></section><section id="block-contentpagerelatedtopics-2" class="block-contentpagerelatedtopics-2 block block-block-content block-block-content68e178e6-e57f-46ce-9a6f-30fe4727ec65"><div  class="topic-list__wrapper de-content-small"><div  class="topic-list"><h2  class="topic-list__title">
        Related Topics
      </h2><ul  class="tag-list__items"><li  class="tag-list__list-item"><a
   class="tag-list__link"
    href="/new-products-promotions"
>
      New Products &amp; Promotions
      </a></li><li  class="tag-list__list-item"><a
   class="tag-list__link"
    href="/frozen-foods"
>
      Frozen Foods
      </a></li></ul></div></div></section><section  id="block-dfptagcontentsidebar2-2" class="ad-block block-dfptagcontentsidebar2-2"><div  class="ad-block__container"><div  class="ad-block__label">
      Advertisement
    </div><div  class="ad-block__spacer" style="min-height:250px"><div id="js-dfp-tag-content_sidebar_2"><script type="text/javascript">
            googletag.cmd.push(function() {
                googletag.display('js-dfp-tag-content_sidebar_2');
            });
    
    </script></div></div></div></section></div></aside><div  class="main__content-footer"><div><section  id="block-dfptagcontentleader2-2" class="ad-block block-dfptagcontentleader2-2"><div  class="ad-block__container"><div  class="ad-block__label">
      Advertisement
    </div><div  class="ad-block__spacer" style="min-height:90px"><div id="js-dfp-tag-content_leader_2"><script type="text/javascript">
            googletag.cmd.push(function() {
                googletag.display('js-dfp-tag-content_leader_2');
            });
    
    </script></div></div></div></section><section id="block-customadcontentleader2-2" class="block-customadcontentleader2-2 block block-block-content block-block-contentb69cb513-20e1-4574-b406-b6cbb4922537"></section></div></div></div><footer  class="site-footer"><div  class="site-footer__inner"><div><section id="block-subscribeblock-2" class="block-subscribeblock-2 block block-block-content block-block-content32ead4d4-16ed-4aa7-bc7b-624d391e39fe"><div id="subscribe"  class="pre-footer"><h2  class="pre-footer__heading">
      Stay Fresh. Stay Progressive.
  </h2><div  class="pre-footer__content"><div  class="cta pre-footer__item"><div  class="cta__content"><h2  class="cta__heading">
      Get the Newsletter
  </h2><div  class="cta__body">
          Get news highlights delivered directly to your e-mail inbox.
        </div></div><a
   class="cta__link cta__link--secondary cta__link--inverse"
      target="_blank"
    href="https://eiq.dragonforms.com/PG_PREFNEW?pk=WEBSITE"
>
      Subscribe
      </a></div><div  class="cta pre-footer__item"><div  class="cta__content"><h2  class="cta__heading">
      Get the Magazine
  </h2><div  class="cta__body">
          See if you qualify for a free subscription to our industry leading paper magazine.
        </div></div><a
   class="cta__link cta__link--secondary cta__link--inverse"
      target="_blank"
    href="https://eiq.dragonforms.com/PG_QUAL?pk=WEBSITE"
>
      Subscribe
      </a></div></div></div></section><section id="block-footersociallinks-2" class="block-footersociallinks-2 block block-block-content block-block-content0c5ef910-9fa8-409c-a45a-b3a5864bd751"><ul  class="social-menu"><li  class="social-menu__item"><a
   class="social-menu__link"
    href="https://www.facebook.com/progressivegrocer"
><svg  class="social-menu__icon"

  
      aria-labelledby="title-facebook"
  
  ><title id="title-facebook">facebook</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#facebook"></use></svg></a></li><li  class="social-menu__item"><a
   class="social-menu__link"
    href="https://twitter.com/pgrocer"
><svg  class="social-menu__icon"

  
      aria-labelledby="title-twitter"
  
  ><title id="title-twitter">twitter</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#twitter"></use></svg></a></li><li  class="social-menu__item"><a
   class="social-menu__link"
    href="https://www.linkedin.com/company/progressive-grocer/about/?viewAsMember=true"
><svg  class="social-menu__icon"

  
      aria-labelledby="title-linkedin"
  
  ><title id="title-linkedin">linkedin</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#linkedin"></use></svg></a></li><li  class="social-menu__item"><a
   class="social-menu__link"
    href="https://www.youtube.com/channel/UCYgh6JPluY5J0b4SE8C3rwA/featured"
><svg  class="social-menu__icon"

  
      aria-labelledby="title-youtube"
  
  ><title id="title-youtube">youtube</title><use xlink:href="/themes/custom/ensemble/dist/icons.svg#youtube"></use></svg></a></li></ul></section><nav role="navigation" aria-labelledby="block-footer-2-menu" id="block-footer-2" class="block-footer-2"><h2 class="block-title visually-hidden" id="block-footer-2-menu">Footer</h2><ul  id="block-footer-2" class="footer-menu block-footer-2"><li  class="footer-menu__item"><a href="/contact-us" class="footer-menu__link" target="" data-drupal-link-system-path="contact-us">Contact Us</a></li><li  class="footer-menu__item"><a href="/advertise" class="footer-menu__link" target="" title="Advertise" data-drupal-link-system-path="node/53866">Advertise</a></li><li  class="footer-menu__item"><a href="http://www.ensembleiq.com/privacy" class="footer-menu__link" target="_blank">Privacy Statement</a></li><li  class="footer-menu__item"><a href="http://www.ensembleiq.com/terms" class="footer-menu__link" target="_blank">Terms &amp; Conditions</a></li></ul></nav><section  id="block-ensemble-dfptaginterstitial1" class="ad-block interstitial-ad block-ensemble-dfptaginterstitial1"><div  class="ad-block__container"><div  class="ad-block__label">
      Advertisement
    </div><div  class="ad-block__spacer" style="min-height:450px"><div id="js-dfp-tag-interstitial_1"><script type="text/javascript">
            googletag.cmd.push(function() {
                googletag.display('js-dfp-tag-interstitial_1');
            });
    
    </script></div></div></div></section></div><div  class="site-footer__logos"><section  class="logo-grid__section"><ul  class="logo-grid logo-grid--default"><li  class="logo-grid__item"><a
   class="link"
      target="_blank"
    href="https://ensembleiq.com"
><img
   class="image"
  loading="lazy"
            src="https://assets1.progressivegrocer.com/files/styles/footer_logo/s3/2021-03/EnsembleIQ-Min-for-web.jpg?itok=Xx__0y-K"
      alt="EnsembleIQ Logo"
          /></a></li><li  class="logo-grid__item"><img
   class="image"
  loading="lazy"
            src="https://assets1.progressivegrocer.com/files/styles/footer_logo/s3/2021-03/PG_New_Logo_footer.png?itok=8xzQCVVT"
      alt="PG Logo"
          /></li></ul></section></div></div><div  class="site-footer__copyright">
              © 2022 EnsembleIQ, All Rights Reserved
          </div></footer></div></section></div><script type="application/json" data-drupal-selector="drupal-settings-json">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</script>
<script src="/sites/default/files/js/js_a5f7FJeurzlPbd1FQ93b0TVh5ewJ03eaT9AbhVv3DpQ.js"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js"></script>
<script src="/sites/default/files/js/js_XQrpDiuxH4CLEhgeabDCTO674zKtgmIJtdE1dE-i6n4.js"></script>
<script src="/modules/custom/eiq/js/image_carousel.js?v=1.15"></script>
<script src="/modules/custom/eiq/js/image_gallery.js?v=1.1"></script>
<script src="/modules/custom/eiq/js/text_boxes.js?v=1"></script>
<script src="/modules/custom/eiq/js/ad_injection.js?v=1.3"></script>
<script src="/modules/custom/eiq/js/cookies.js?v=1"></script>
<script src="/modules/custom/ash_util/js/spin.min.js?v=9.3.14"></script>
<script src="/modules/custom/ash_util/js/spinner.js?v=9.3.14"></script>
<script src="/modules/custom/ash_util/js/processing_indicator.js?v=9.3.14"></script>
<script src="/modules/custom/eiq/js/show_more.js?re2ko9"></script>
<script src="/modules/custom/eiq/js/site_admin_menu.js?v=1.1"></script>
<script src="/modules/custom/eiq/js/dfp.js?v=1"></script>
<script src="/sites/default/files/js/js_tu9DZ4csbbpaVVX0oQLg3or83Nq0FCVClBEAVNF_dtE.js"></script>
<script src="/themes/custom/ensemble/components/01-atoms/images/icons/svgxuse.min.js?re2ko9" defer></script>
<script src="/sites/default/files/js/js_rEz_4nELlKCvo55XQWyof-n2Mdy32NSIwlpY4oj0yVk.js"></script>
<script src="https://app.credspark.com/embed-v2.js"></script>
<script src="/sites/default/files/js/js_epuvclMXc5rqX9fLMTAgtGwvhs8Qt_-FHT-SiQ007Yk.js"></script>
<div id="mega-modal" class="reveal-modal" data-reveal aria-hidden="true" role="dialog"><a class="overlay-close"></a></div>    <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"75a2a2a512","applicationID":"75378380","transactionName":"YQEBZUVTXEZUVEMLC1hLIlJDW11bGkdWBQFpBwJSX1c=","queueTime":0,"applicationTime":14,"atts":"TUYCEw1JT0g=","errorBeacon":"bam.nr-data.net","agent":""}</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"722309f85ebb5cc4","token":"3c33cfdca9be417d9995dafca100bfaf","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body>
  </html>
